AutoMile

Download Old Versions of AutoMile

I'm leaving AutoMile 1.4 available for download for the time being, for those of you that purchased AutoMile directly from my website and cannot upgrade to Mac OS X 10.9. If you purchased AutoMile through the Mac App Store, you should still be able to download an older version through the store.

AutoMile 1.4 — January 23, 2014
Requirements: Mac OS X 10.7.5 or later.
Mac OS X 10.9 "Mavericks" compatible.
AutoMile should work in any country that is supported by Google Maps.

Lost Licenses

Please contact me if you need me to email your license to you again. Please provide any information that I can use to find your order: name, order number, etc. Thanks!